Bluetooth problems

Discussion in 'General chat' started by blackrat, Feb 13, 2019.

  1. blackrat
    Offline

    blackrat

    Joined:
    Aug 19, 2015
    Messages:
    36
    Likes Received:
    10
    Location:
    Plymouth
    Ratings:
    +12 / 0 / -0
    Good evening all

    I am hoping that someone from within our knowledgeable members can assist with the following issue

    until recently the hands free phone system has worked as it should on my car (if it makes any difference an '06 E91 non idrive) but has now stopped,

    I don't know if it is to do with the head unit as the symbol on the screen indicating that the phone and unit are connected has disappeared or whether there is a separate module if there is such a part for the Bluetooth.

    if I try to re-pair my phone from scratch the TEL button doesn't do anything. it is definitely not my phone as all other Bluetooth pairings still work

    if it is the Bluetooth module I have been advised that it is under the floor in the boot, is this correct

    thanks in advance
     
  2. markyboyt
    Offline

    markyboyt

    Joined:
    Aug 16, 2015
    Messages:
    544
    Likes Received:
    96
    Location:
    Shropshire
    Ratings:
    +168 / 0 / -0
    Yes the telephone control unit is in the boot, I’m sure it’s in the same place as the e90 and e92 under the boot floor right being the seats but it might need a few clips removing on the E91. If the symbol is being lost off the head unit and just going to the 2 dashes then it’s almost always the telephone control unit itself at fault, obviously best to check things like MOST is intact and that the fuse for the ecu is ok.
     
    Last edited: Feb 14, 2019
  3. blackrat
    Offline

    blackrat

    Joined:
    Aug 19, 2015
    Messages:
    36
    Likes Received:
    10
    Location:
    Plymouth
    Ratings:
    +12 / 0 / -0
    mark, thank you for that
    you mention the 'telephone control unit' is that the same component as you describe in the boot or should I be looking somewhere else ??
     
  4. JasonH
    Offline

    JasonH

    Joined:
    Sep 1, 2015
    Messages:
    163
    Likes Received:
    53
    Ratings:
    +79 / 0 / -0
    Yes the TCU is usually located in the boot under the floor. They do fail so that is likely to be the problem.
     
  5. markyboyt
    Offline

    markyboyt

    Joined:
    Aug 16, 2015
    Messages:
    544
    Likes Received:
    96
    Location:
    Shropshire
    Ratings:
    +168 / 0 / -0
    yes that's the same component
     

Share This Page