BMW 2007 116i Brake pads, errors and advice

Discussion in '1 Series' started by Bogdan, Oct 11, 2019.

  1. Bogdan
    Offline

    Bogdan

    Joined:
    Oct 11, 2019
    Messages:
    2
    Likes Received:
    0
    Ratings:
    +0 / 0 / -0
    Hello there, I have a 2007 116i M sport for 2 weeks and after I serviced it to clear all the dash errors, I had a sensor that needed to be replaced which I did then after a couple of days I pull out of my car park then I stole the engine [​IMG][​IMG] but when I turn the car back on, the dash goes with 4 errors one of them being rear brake bulb which was replaced when I serviced it, it burned again, I changed it so the error has gone, I am left with CC-ID 50, CC-ID 24 and CC-ID 42, to mention that I was in traffic on a downhill country road where I was braking longer than I should have then I was hearing a kind of creaking noise when I was going slow at ~10 mph and my parking brake does not hold the car at all, if I pull it all the way up and is on neutral with engine running i can push the car with one finger to move it [​IMG], any ideas on those? To mention that I couldn't leave my car once to a hill parking bay in gear as it was not holding it at all ( IN GEAR ) which scared me a little bit. I want to get a set of new brake pads but as my car is M Sport, which brand is it recommended and suitable for M sport suspension as I saw some of them are not suitable.
    To also mention that the car does not steer any left or right when braking and does not feel anything on the steering wheel

    In regards of the errors, I can not activate Cruise Control and the DTC off symbol keeps being on dash as well so it's off and if I press the button it does nothing, it use to work before this happend.

    Any ideas and recommendation on these issues will be greatly appreciated!
    Thanks in advance
     
  2. bishbosh
    Offline

    bishbosh WARLORD Site Supporter

    Joined:
    Aug 15, 2015
    Messages:
    1,287
    Likes Received:
    459
    Ratings:
    +722 / 3 / -0
    Eeee and I thought Lord of the Rings was a slog!
     
    • Funny Funny x 2
  3. Bogdan
    Offline

    Bogdan

    Joined:
    Oct 11, 2019
    Messages:
    2
    Likes Received:
    0
    Ratings:
    +0 / 0 / -0
    Thanks for help
     
  4. bishbosh
    Offline

    bishbosh WARLORD Site Supporter

    Joined:
    Aug 15, 2015
    Messages:
    1,287
    Likes Received:
    459
    Ratings:
    +722 / 3 / -0
    Have you had the codes read with a bmw specific diagnostic tool?
     
  5. slim_boy_fat
    Offline

    slim_boy_fat WARLORD Site Supporter

    Joined:
    Jul 31, 2015
    Messages:
    3,147
    Likes Received:
    1,005
    Location:
    Scottish Highlands
    Ratings:
    +1,906 / 1 / -2
    Welcome aboard :wavey:, but can you try breaking your post(s) into paragraphs please, in a long box of text like yours it can be difficult to get the full sense of what you're asking - which is what @bishbosh was alluding. He's actually very knowledgeable and helpful about BMWs on the forum (y)
     
  6. snrbrtsn
    Offline

    snrbrtsn WARLORD Site Supporter

    Joined:
    Jul 30, 2015
    Messages:
    1,881
    Likes Received:
    705
    Location:
    Aberdeen
    Ratings:
    +1,143 / 0 / -2
    Abs reluctor ring or sensor fault
     

Share This Page