E61 520d lci running problems, can anyone help please

Discussion in 'Data and Info' started by Donny, Oct 8, 2019.

  1. Donny
    Offline

    Donny

    Joined:
    Oct 8, 2019
    Messages:
    6
    Likes Received:
    0
    Ratings:
    +0 / 0 / -0
    Hi folks
    I’ve been having problems with rough idle, cutting out and zero power.
    I plugged the car into my ethos and it has came up dpf and egr deactivated, I have taken the egr off and it wasn’t stuck so I have taken the dpf off (not fitted new one yet) started the can and still rough but seems to run fine with the vacuum pipe removed from the egr, does anyone know if this means the egr is indeed faulty? I haven’t driven the car due to the dpf being removed.
    Any help with this woukd be greatly appreciated
    Thanks
    Donny


    Sent from my iPhone using Tapatalk
     
  2. JasonH
    Offline

    JasonH

    Joined:
    Sep 1, 2015
    Messages:
    185
    Likes Received:
    61
    Ratings:
    +92 / 0 / -0
    They do run better with the EGR deactivated by removing the vacuum hose, even on a car that is otherwise fine.

    Is your DPF clogged up - cutting out and zero power can be a fully blocked DPF.

    Driving without a DPF may generate fault codes and trigger limp mode because the exhaust back pressure is too low.
     
  3. Donny
    Offline

    Donny

    Joined:
    Oct 8, 2019
    Messages:
    6
    Likes Received:
    0
    Ratings:
    +0 / 0 / -0
    Hi Jason thanks for your reply
    I’ve took the dpf off the car altogether and thought I’d start it to see how it ran before fitting the new one, it ran exactly the same as it was (cutting out and wouldn’t rev) until I took the vacuum pipe off then it was ticking over nice and revving freely so I’m wondering if it has been the egr all along or the solenoid for it


    Sent from my iPhone using Tapatalk
     
  4. JasonH
    Offline

    JasonH

    Joined:
    Sep 1, 2015
    Messages:
    185
    Likes Received:
    61
    Ratings:
    +92 / 0 / -0
    Normally on these the EGR just gets all gummed up.

    It should be closed with no vacuum connected so it sounds like it is closing. It could be sticking open and it would be worth taking it off and giving it a good clean.
     
  5. Singvogel
    Offline

    Singvogel Moderator WARLORD Site Supporter

    Joined:
    Jul 31, 2015
    Messages:
    1,725
    Likes Received:
    808
    Location:
    Aberdeenshire, BiH, or somewhere in between.
    Ratings:
    +1,085 / 0 / -0
    If it's not throwing any error codes or warning lights I would leave the EGR vacuum pipe disconnected.

    It was only a ploy to pretend they were taking steps to reduce emissions and it's pretty ineffectual.

    All you have to do is plug the open end of the vacuum pipe with a small plastic peg.

    A golf tee is perfect for the job.

    My E46 M47 engine did over 120K like that and ran as sweet as a nut.
     
    • Like Like x 1
  6. Donny
    Offline

    Donny

    Joined:
    Oct 8, 2019
    Messages:
    6
    Likes Received:
    0
    Ratings:
    +0 / 0 / -0
    Ok so an update on the 520d, fitted a new dpf and car seems to be running good on a ten mile test drive, no warning lights but decided to plug the ethos back in to see if anything comes up and it’s saying “452a particulate filter” anybody got any ideas?


    Sent from my iPhone using Tapatalk
     
  7. JasonH
    Offline

    JasonH

    Joined:
    Sep 1, 2015
    Messages:
    185
    Likes Received:
    61
    Ratings:
    +92 / 0 / -0
    First clear the fault and see if it comes back.

    How many miles has the car done?
     
    • Like Like x 1
  8. bishbosh
    Offline

    bishbosh WARLORD Site Supporter

    Joined:
    Aug 15, 2015
    Messages:
    1,287
    Likes Received:
    459
    Ratings:
    +722 / 3 / -0
    When you fitted the dpf did you register the change with the DDE?
     
  9. Donny
    Offline

    Donny

    Joined:
    Oct 8, 2019
    Messages:
    6
    Likes Received:
    0
    Ratings:
    +0 / 0 / -0
    Hi Jason
    Yes I cleared the fault but only with the ethos (not sure if I need something better)
    The car has just turned over to 120k


    Sent from my iPhone using Tapatalk
     
  10. Donny
    Offline

    Donny

    Joined:
    Oct 8, 2019
    Messages:
    6
    Likes Received:
    0
    Ratings:
    +0 / 0 / -0
    Hi bishbosh
    Excuse my ignorance but what is dde?


    Sent from my iPhone using Tapatalk
     
  11. JasonH
    Offline

    JasonH

    Joined:
    Sep 1, 2015
    Messages:
    185
    Likes Received:
    61
    Ratings:
    +92 / 0 / -0
    DDE is Digital Drive Electronics, the main engine ECU.

    The reason I asked about mileage is that on the LCi models there is a hidden mileage limit on the DPF. Once it exceeds (I think 155k miles) the error code comes up.

    To clear the mileage limit fault code you need to use diagnostics to tell the DDE that a new DPF has been fitted. It'll be a something like a "service function" in the diagnostics.
     
    • Informative Informative x 1
  12. Postman
    Offline

    Postman

    Joined:
    Aug 24, 2015
    Messages:
    82
    Likes Received:
    25
    Ratings:
    +44 / 0 / -0
    Google should be your friend here with reset on the computer. I did it a few years ago on mine. Not at home atm so cannot check how I actually went about it, but it must be easy enough....
     
  13. Donny
    Offline

    Donny

    Joined:
    Oct 8, 2019
    Messages:
    6
    Likes Received:
    0
    Ratings:
    +0 / 0 / -0
    That’s some good advice guys thank you, I have reset the dpf through my ethos and the fault is not showing anymore.

    The car seems to be running great but only with the vacuum pipe removed from the egr valve but I’m not sure if it’s as good as it should be as the car is new to me


    Sent from my iPhone using Tapatalk
     

Share This Page