Looking for advice please - DSC failure, code: 00D373

Discussion in '3 Series' started by Ashmobes, Feb 12, 2019.

  1. Ashmobes
    Offline

    Ashmobes

    Joined:
    Feb 12, 2019
    Messages:
    3
    Likes Received:
    0
    Ratings:
    +0 / 0 / -0
    Hi,

    I'm getting a DSC failure with the error code 00D373 F-CAN SWA-Top sensor message 200 or 201 missing, does anyone know what this is? I've tried clearing the code but it came back week or so later.

    I have tried using the search bar but couldn't find anything covering this specific issue so appoligies if it's been covered before.
     
  2. Alan Gunn
    Offline

    Alan Gunn

    Joined:
    Feb 13, 2018
    Messages:
    104
    Likes Received:
    26
    Location:
    Anglesey
    Ratings:
    +47 / 0 / -0
    Have you put that code in a google search.
    Comes up with steering angle sensor when i put it in but a lot to look through as well.
     
  3. Adie
    Offline

    Adie WARLORD Site Supporter

    Joined:
    Jan 15, 2016
    Messages:
    1,063
    Likes Received:
    269
    Location:
    Milton Keynes
    Ratings:
    +558 / 1 / -1
    Could be that one of the YAW rate sensors have failed. Which model do you have? Is the airbag light illuminated?
     
    Last edited: Feb 13, 2019
  4. Ashmobes
    Offline

    Ashmobes

    Joined:
    Feb 12, 2019
    Messages:
    3
    Likes Received:
    0
    Ratings:
    +0 / 0 / -0
    E90 320d 2006. The airbag light is not illuminated
     
  5. Adie
    Offline

    Adie WARLORD Site Supporter

    Joined:
    Jan 15, 2016
    Messages:
    1,063
    Likes Received:
    269
    Location:
    Milton Keynes
    Ratings:
    +558 / 1 / -1
  6. slim_boy_fat
    Offline

    slim_boy_fat WARLORD Site Supporter

    Joined:
    Jul 31, 2015
    Messages:
    2,810
    Likes Received:
    862
    Ratings:
    +1,651 / 1 / -2
    Oddly enough, I had this very thing on the e60 [which has Dynamic Drive and Active Steering] on Monday last. I knew what had caused it in my case - I reversed up and round a steep driveway, possibly using full lock. Active Steering warning appeared on the dash but the steering response(s) felt 'normal'. As I was near home I carried on and left it when I arrived. Next day, when I went to fix it, the warning had disappeared so I assume that 24hrs sitting dead level allowed it to reset.
    I've had the same in the past and declined BMWs kind offer of diagnostic charges :whistling: and did some Googling. There is a reset procedure which I tried and it cured it, but it would randomly appear later. Patience, perseverance and a good grip on a wallet :D finally got it fixed. It depended on getting the steering wheel aligned at the exact dead-ahead position and I never saw it again [well......until Monday :rolleyeses: ]. I'd obviously been a degree or two with my alignment on the previous attempts. :oops:

    Good luck in finding a solution, there's nothing worse than the "BONG" of impending death - even the outside temp alert scares me........:crash:
     
    • Funny Funny x 4
    Last edited: Feb 13, 2019
  7. Ashmobes
    Offline

    Ashmobes

    Joined:
    Feb 12, 2019
    Messages:
    3
    Likes Received:
    0
    Ratings:
    +0 / 0 / -0
    I'm using a Carly adaptor
     

Share This Page