Secondary Air Pump E60 2004 545i Error on both banks

Discussion in '5 Series' started by eggnchips, Mar 12, 2019.

  1. eggnchips
    Offline

    eggnchips

    Joined:
    Feb 21, 2018
    Messages:
    11
    Likes Received:
    11
    Ratings:
    +11 / 0 / -0
    Hi
    I have a Secondary air fault error coming up on both banks. Does anyone know if changing the pump will clear this up please.
     
  2. snrbrtsn
    Offline

    snrbrtsn WARLORD Site Supporter

    Joined:
    Jul 30, 2015
    Messages:
    1,748
    Likes Received:
    648
    Location:
    Aberdeen
    Ratings:
    +1,027 / 0 / -1
  3. eggnchips
    Offline

    eggnchips

    Joined:
    Feb 21, 2018
    Messages:
    11
    Likes Received:
    11
    Ratings:
    +11 / 0 / -0
    Thanks for coming back, I have just been out again and checked the codes and am getting 2760 and 2761. I will check your suggestion tomorrow and have a look at the pump if no joy. There do seem to be mixed messages around how to deal with this, they seem to relate mainly to carbon build up
     
  4. snrbrtsn
    Offline

    snrbrtsn WARLORD Site Supporter

    Joined:
    Jul 30, 2015
    Messages:
    1,748
    Likes Received:
    648
    Location:
    Aberdeen
    Ratings:
    +1,027 / 0 / -1
    My neighbour has a 545i
    His car was running terrible with multiple codes until we replaced the pipe above
    The top left connection is in path of most heat, his had disintegrated on the lower connector
    Worth a check as it’s only the engine cover that needs removed to check
     
    • Like Like x 1
  5. eggnchips
    Offline

    eggnchips

    Joined:
    Feb 21, 2018
    Messages:
    11
    Likes Received:
    11
    Ratings:
    +11 / 0 / -0
    Thanks for coming back, I have the cover and checked the pipes, they look quite new. Just to check I ran the engine and squirted the pipes and joints with WD40 to see if there was any reaction or change in engine note. No joy
     
  6. markyboyt
    Offline

    markyboyt

    Joined:
    Aug 16, 2015
    Messages:
    545
    Likes Received:
    97
    Location:
    Shropshire
    Ratings:
    +169 / 0 / -0
    Whats the fault description or fault code say? have you read the faults with a generic OBD reader or a BMW specific one?
     
  7. eggnchips
    Offline

    eggnchips

    Joined:
    Feb 21, 2018
    Messages:
    11
    Likes Received:
    11
    Ratings:
    +11 / 0 / -0
    its 2760 and 2761 on a generic reader which does crop up on other forums. Carly isn't showing anything. Main symptoms are a slightly lumpy idle which has gotten worse over the past few months. Given the age of the car (200) I was always surprised at the even idle.
     
  8. markyboyt
    Offline

    markyboyt

    Joined:
    Aug 16, 2015
    Messages:
    545
    Likes Received:
    97
    Location:
    Shropshire
    Ratings:
    +169 / 0 / -0
    Can you hear any airleaks or anything untoward from the engine?
     
  9. eggnchips
    Offline

    eggnchips

    Joined:
    Feb 21, 2018
    Messages:
    11
    Likes Received:
    11
    Ratings:
    +11 / 0 / -0
    No Funny noises and no loss of power, no increase in fuel consumption and no plumes of smoke. Looking at REALOEM, there is a filter near the pump behind the inner wing. I might take a look at that
     

Share This Page